mirror of
https://github.com/pine64/blisp.git
synced 2024-12-21 22:10:12 +00:00
3490c37581
This adds a Nix flake, shims for 'legacy' Nix, and a `.envrc` for `direnv`. blisp is now able to run directly via: `nix run github:pine64/blisp` and for Nix/NixOS users, this helps with a one-click developer environment. Signed-off-by: Dom Rodriguez <shymega@shymega.org.uk>
45 lines
924 B
Nix
45 lines
924 B
Nix
{
|
|
description = "A very basic flake";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs?ref=nixos-unstable";
|
|
};
|
|
|
|
outputs =
|
|
{ self, nixpkgs, ... }@inputs:
|
|
let
|
|
systems = [
|
|
"x86_64-linux"
|
|
"aarch64-linux"
|
|
];
|
|
forEachSystem = nixpkgs.lib.genAttrs systems;
|
|
in
|
|
{
|
|
packages = forEachSystem (
|
|
system:
|
|
let
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
in
|
|
with pkgs;
|
|
{
|
|
blisp = callPackage ./blisp.nix { inherit self; };
|
|
default = self.packages.${system}.blisp;
|
|
}
|
|
);
|
|
|
|
devShells = forEachSystem (
|
|
system:
|
|
let
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
in
|
|
with pkgs;
|
|
{
|
|
default = mkShell {
|
|
name = "blisp-dev";
|
|
nativeBuildInputs = [ self.packages.${system}.default ];
|
|
};
|
|
}
|
|
);
|
|
};
|
|
}
|